CVE-2014-2891

NameCVE-2014-2891
DescriptionstrongSwan before 5.1.2 allows remote attackers to cause a denial of service (NULL pointer dereference and IKE daemon crash) via a crafted ID_DER_ASN1_DN ID payload.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2922-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
strongswan (PTS)squeeze, squeeze (security)4.4.1-5.6fixed
squeeze (lts)4.4.1-5.7fixed
wheezy4.5.2-1.5+deb7u4fixed
wheezy (security)4.5.2-1.5+deb7u7fixed
jessie5.2.1-6fixed
jessie (security)5.2.1-6+deb8u1fixed
stretch, sid5.3.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
strongswansource(unstable)5.1.2-1medium
strongswansourcesqueeze4.4.1-5.6mediumDSA-2922-1
strongswansourcewheezy4.5.2-1.5+deb7u4mediumDSA-2922-1

Search for package or bug name: Reporting problems