CVE-2014-2894

NameCVE-2014-2894
DescriptionOff-by-one error in the cmd_smart function in the smart self test in hw/ide/core.c in QEMU before 2.0 allows local users to have unspecified impact via a SMART EXECUTE OFFLINE command that triggers a buffer underflow and memory corruption.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2932-1, DSA-2933-1
NVD severityhigh (attack range: local)
Debian Bugs745157

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)wheezy1.1.2+dfsg-6a+deb7u12fixed
wheezy (security)1.1.2+dfsg-6+deb7u24fixed
jessie (security), jessie1:2.1+dfsg-12+deb8u6fixed
stretch1:2.8+dfsg-6+deb9u2fixed
stretch (security)1:2.8+dfsg-6+deb9u3fixed
buster, sid1:2.10.0+dfsg-2fixed
qemu-kvm (PTS)wheezy1.1.2+dfsg-6+deb7u12fixed
wheezy (security)1.1.2+dfsg-6+deb7u24fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)2.0.0+dfsg-1high745157
qemusourcesqueeze(not affected)
qemusourcewheezy1.1.2+dfsg-6a+deb7u3highDSA-2932-1
qemu-kvmsource(unstable)(unfixed)high
qemu-kvmsourcesqueeze(not affected)
qemu-kvmsourcewheezy1.1.2+dfsg-6+deb7u3highDSA-2933-1

Notes

[squeeze] - qemu <not-affected> (Vulnerable code not present)
[squeeze] - qemu-kvm <not-affected> (Vulnerable code not present)
Upstream fix https://lists.nongnu.org/archive/html/qemu-devel/2014-04/msg02016.html
Vulnerable code introduced in 0.11.50: http://git.qemu.org/?p=qemu.git;a=commit;h=e8b54394950f975c1b31d2359cf58ca4d9f51b00

Search for package or bug name: Reporting problems