CVE-2014-2902

NameCVE-2014-2902
Descriptionwolfssl before 3.2.0 does not properly authorize CA certificate for signing other certificates.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs770229, 792646

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wolfssl (PTS)bullseye4.6.0+p1-0+deb11u2fixed
bookworm5.5.4-2+deb12u1fixed
trixie, sid5.7.0-0.3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cyasslsource(unstable)(unfixed)770229
wolfsslsource(unstable)3.4.8+dfsg-1792646

Notes

wolfssl actually fixed with the initial upload to unstable after the rename
according to maintainer addressed in 3.2.0 upstream

Search for package or bug name: Reporting problems