CVE-2014-2980

NameCVE-2014-2980
DescriptionTools/gdomap.c in gdomap in GNUstep Base 1.24.6 and earlier, when run in daemon mode, does not properly handle the file descriptor for the logger, which allows remote attackers to cause a denial of service (abort) via an invalid request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs745470

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnustep-base (PTS)stretch1.24.9-3.1+deb9u1fixed
buster1.26.0-4+deb10u1fixed
bullseye1.27.0-3fixed
bookworm, sid1.28.0-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnustep-basesourcewheezy1.22.1-4+deb7u1
gnustep-basesource(unstable)1.24.6-1745470

Notes

[squeeze] - gnustep-base <no-dsa> (Minor issue)
https://savannah.gnu.org/bugs/?41751

Search for package or bug name: Reporting problems