CVE-2014-3007

NameCVE-2014-3007
DescriptionPython Image Library (PIL) 1.1.7 and earlier and Pillow 2.3 might allow remote attackers to execute arbitrary commands via shell metacharacters in unspecified vectors related to CVE-2014-1932, possibly JpegImagePlugin.py.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs737059

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pillow (PTS)stretch4.0.0-4+deb9u1fixed
stretch (security)4.0.0-4+deb9u3fixed
buster5.4.1-2+deb10u2fixed
buster (security)5.4.1-2+deb10u1fixed
bullseye8.1.2+dfsg-0.3fixed
bookworm, sid8.3.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pillowsource(unstable)2.4.0-1737059
python-imagingsource(unstable)(unfixed)

Notes

[squeeze] - python-imaging <no-dsa> (Minor issue)
[wheezy] - python-imaging <no-dsa> (Minor issue)
details what is covered exactly by this CVE relating to CVE-2014-1932 and CVE-2014-1933 is missing

Search for package or bug name: Reporting problems