CVE-2014-3137

NameCVE-2014-3137
DescriptionBottle 0.10.x before 0.10.12, 0.11.x before 0.11.7, and 0.12.x before 0.12.6 does not properly limit content types, which allows remote attackers to bypass intended access restrictions via an accepted Content-Type followed by a ; (semi-colon) and a Content-Type that would not be accepted, as demonstrated in YouCompleteMe to execute arbitrary code.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2948-1
NVD severitymedium (attack range: remote)
Debian Bugs746322
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-bottle (PTS)squeeze0.8.4-1fixed
wheezy, wheezy (security)0.10.11-1+deb7u1fixed
stretch, jessie, sid0.12.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-bottlesource(unstable)0.12.6-1medium746322
python-bottlesourcesqueeze(not affected)
python-bottlesourcewheezy0.10.11-1+deb7u1mediumDSA-2948-1

Notes

[squeeze] - python-bottle <not-affected> (bug affects versions 0.10.11-1 and 0.12.5-1)

Search for package or bug name: Reporting problems