CVE-2014-3182

NameCVE-2014-3182
DescriptionArray index error in the logi_dj_raw_event function in drivers/hid/hid-logitech-dj.c in the Linux kernel before 3.16.2 allows physically proximate attackers to execute arbitrary code or cause a denial of service (invalid kfree) via a crafted device that provides a malformed REPORT_TYPE_NOTIF_DEVICE_UNPAIRED value.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie (security), jessie3.16.56-1+deb8u1fixed
stretch4.9.82-1+deb9u3fixed
stretch (security)4.9.88-1+deb9u1fixed
buster4.16.12-1fixed
sid4.16.16-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)3.16.2-2medium
linuxsourcewheezy3.2.63-1medium
linux-2.6source(unstable)(not affected)

Notes

- linux-2.6 <not-affected> (Vulnerable driver introduced later)
https://code.google.com/p/google-security-research/issues/detail?id=89
Upstream fix: https://git.kernel.org/linus/ad3e14d7c5268c2e24477c6ef54bbdf88add5d36 (v3.17-rc2)

Search for package or bug name: Reporting problems