CVE-2014-3462

NameCVE-2014-3462
DescriptionThe ".encfs6.xml" configuration file in encfs before 1.7.5 allows remote attackers to access sensitive data by setting "blockMACBytes" to 0 and adding 8 to "blockMACRandBytes".
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs736066

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
encfs (PTS)jessie1.7.4-5vulnerable
stretch1.9.1-4fixed
buster, sid1.9.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
encfssource(unstable)1.8.1-1low736066

Notes

[jessie] - encfs <no-dsa> (Minor issue)
[squeeze] - encfs <no-dsa> (Minor issue)
[wheezy] - encfs <no-dsa> (Minor issue)
Shortcoming documented in 1.7.4-4
https://defuse.ca/audits/encfs.htm
Upstream issue: https://github.com/vgough/encfs/issues/14

Search for package or bug name: Reporting problems