CVE-2014-3466

NameCVE-2014-3466
DescriptionBuffer overflow in the read_server_hello function in lib/gnutls_handshake.c in GnuTLS before 3.1.25, 3.2.x before 3.2.15, and 3.3.x before 3.3.4 allows remote servers to cause a denial of service (memory corruption) or possibly execute arbitrary code via a long session id in a ServerHello message.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDLA-0001-1, DSA-2944-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablepackage gnutls26 is vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnutls26 (PTS)squeeze, squeeze (security)2.8.6-1+squeeze3vulnerable
squeeze (lts)2.8.6-1+squeeze5fixed
wheezy2.12.20-8+deb7u2fixed
wheezy (security)2.12.20-8+deb7u3fixed
gnutls28 (PTS)jessie3.3.8-6+deb8u1fixed
stretch, sid3.3.15-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnutls26source(unstable)2.12.23-16medium
gnutls26sourcesqueeze2.8.6-1+squeeze4medium
gnutls26sourcewheezy2.12.20-8+deb7u2mediumDSA-2944-1
gnutls28source(unstable)3.2.15-1medium

Notes

http://radare.today/technical-analysis-of-the-gnutls-hello-vulnerability/

Search for package or bug name: Reporting problems