CVE-2014-3471

NameCVE-2014-3471
DescriptionUse-after-free vulnerability in hw/pci/pcie.c in QEMU (aka Quick Emulator) allows local guest OS users to cause a denial of service (QEMU instance crash) via hotplug and hotunplug operations of Virtio block devices.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie1:2.1+dfsg-12+deb8u6fixed
jessie (security)1:2.1+dfsg-12+deb8u7fixed
stretch (security), stretch1:2.8+dfsg-6+deb9u4fixed
buster, sid1:2.12+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)2.1+dfsg-1low
qemusourcesqueeze(not affected)
qemusourcewheezy(not affected)
qemu-kvmsource(unstable)(unfixed)low
qemu-kvmsourcesqueeze(not affected)
qemu-kvmsourcewheezy(not affected)

Notes

[wheezy] - qemu <not-affected> (Vulnerable code not present)
[wheezy] - qemu-kvm <not-affected> (Vulnerable code not present)
[squeeze] - qemu <not-affected> (Vulnerable code not present)
[squeeze] - qemu-kvm <not-affected> (Vulnerable code not present)
https://lists.gnu.org/archive/html/qemu-devel/2014-06/msg05283.html
Upstream fix: http://git.qemu.org/?p=qemu.git;a=commit;h=554f802da3f8b09b16b9a84ad5847b2eb0e9ad2b (v2.1.0-rc0)
PCIe support introduced in v1.3: http://wiki.qemu.org/ChangeLog/1.3

Search for package or bug name: Reporting problems