CVE-2014-3477

NameCVE-2014-3477
DescriptionThe dbus-daemon in D-Bus 1.2.x through 1.4.x, 1.6.x before 1.6.20, and 1.8.x before 1.8.4, sends an AccessDenied error to the service instead of a client when the client is prohibited from accessing the service, which allows local users to cause a denial of service (initialization failure and exit) or possibly conduct a side-channel attack via a D-Bus message to an inactive service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-87-1, DSA-2971-1
NVD severitylow (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dbus (PTS)wheezy, wheezy (security)1.6.8-1+deb7u6fixed
jessie1.8.22-0+deb8u1fixed
buster, sid, stretch1.10.18-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dbussource(unstable)1.8.4-1low
dbussourcesqueeze1.2.24-4+squeeze3lowDLA-87-1
dbussourcewheezy1.6.8-1+deb7u3lowDSA-2971-1

Notes

[squeeze] - dbus <no-dsa> (Minor issue)
https://bugs.freedesktop.org/show_bug.cgi?id=78979

Search for package or bug name: Reporting problems