CVE-2014-3478

NameCVE-2014-3478
DescriptionBuffer overflow in the mconvert function in softmagic.c in file before 5.19, as used in the Fileinfo component in PHP before 5.4.30 and 5.5.x before 5.5.14, allows remote attackers to cause a denial of service (application crash) via a crafted Pascal string in a FILE_PSTRING conversion.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDLA-27-1, DSA-2974-1, DSA-3021-1
NVD severitymedium (attack range: remote)
Debian/oldstablepackage file is vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
file (PTS)squeeze (security), squeeze5.04-5+squeeze5vulnerable
squeeze (lts)5.04-5+squeeze9fixed
wheezy5.11-2+deb7u6fixed
wheezy (security)5.11-2+deb7u7fixed
jessie1:5.20-2fixed
sid1:5.22+15-1fixed
php5 (PTS)squeeze (security), squeeze5.3.3-7+squeeze19fixed
squeeze (lts)5.3.3-7+squeeze25fixed
wheezy5.4.36-0+deb7u1fixed
wheezy (security)5.4.36-0+deb7u3fixed
jessie5.6.5+dfsg-2fixed
sid5.6.6+dfsg-2fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
filesource(unstable)1:5.19-1medium
filesourcesqueeze5.04-5+squeeze6medium
filesourcewheezy5.11-2+deb7u4mediumDSA-3021-1
php5source(unstable)5.6.0~rc1+dfsg-1medium
php5sourcesqueeze(not affected)
php5sourcewheezy5.4.4-14+deb7u12mediumDSA-2974-1

Notes

https://github.com/file/file/commit/27a14bc7ba285a0a5ebfdb55e54001aa11932b08
[squeeze] - php5 <not-affected> (Vulnerable code was introduced later)
http://bugs.php.net/bug.php?id=67410

Search for package or bug name: Reporting problems