CVE-2014-3480

NameCVE-2014-3480
DescriptionThe cdf_count_chain function in cdf.c in file before 5.19, as used in the Fileinfo component in PHP before 5.4.30 and 5.5.x before 5.5.14, does not properly validate sector-count data, which allows remote attackers to cause a denial of service (application crash) via a crafted CDF file.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDLA-0018-1, DLA-27-1, DSA-2974-1, DSA-3021-1
NVD severitymedium (attack range: remote, user-initiated)
Debian/oldoldstablepackages file, php5 are vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
file (PTS)squeeze, squeeze (security)5.04-5+squeeze5vulnerable
squeeze (lts)5.04-5+squeeze10fixed
wheezy5.11-2+deb7u6fixed
wheezy (security)5.11-2+deb7u8fixed
stretch, sid, jessie1:5.22+15-2fixed
php5 (PTS)squeeze, squeeze (security)5.3.3-7+squeeze19vulnerable
squeeze (lts)5.3.3.1-7+squeeze26fixed
wheezy5.4.36-0+deb7u1fixed
wheezy (security)5.4.39-0+deb7u2fixed
jessie5.6.7+dfsg-1fixed
stretch, sid5.6.9+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
filesource(unstable)1:5.19-1medium
filesourcesqueeze5.04-5+squeeze6medium
filesourcewheezy5.11-2+deb7u4mediumDSA-3021-1
php5source(unstable)5.6.0~rc1+dfsg-1medium
php5sourcesqueeze5.3.3-7+squeeze21medium
php5sourcewheezy5.4.4-14+deb7u12mediumDSA-2974-1

Notes

https://github.com/file/file/commit/40bade80cbe2af1d0b2cd0420cebd5d5905a2382
http://bugs.php.net/bug.php?id=67412

Search for package or bug name: Reporting problems