CVE-2014-3482

NameCVE-2014-3482
DescriptionSQL injection vulnerability in activerecord/lib/active_record/connection_adapters/postgresql_adapter.rb in the PostgreSQL adapter for Active Record in Ruby on Rails 2.x and 3.x before 3.2.19 allows remote attackers to execute arbitrary SQL commands by leveraging improper bitstring quoting.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2982-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)stretch2:4.2.7.1-1+deb9u2fixed
stretch (security)2:4.2.7.1-1+deb9u4fixed
buster, buster (security)2:5.2.2.1+dfsg-1+deb10u2fixed
bullseye, sid2:6.0.3.5+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssourcesqueeze(unfixed)end-of-life
railssourcewheezy(not affected)
railssource(unstable)2:4.1.4-1
rails-3.2source(unstable)3.2.19-1
rails-4.0source(unstable)(unfixed)
ruby-activerecord-2.3sourcewheezy(unfixed)end-of-life
ruby-activerecord-2.3source(unstable)(unfixed)
ruby-activerecord-3.2sourcewheezy3.2.6-5+deb7u1DSA-2982-1
ruby-activerecord-3.2source(unstable)(unfixed)

Notes

[wheezy] - rails <not-affected> (src:rails in wheezy is just a transition package)
[squeeze] - rails <end-of-life> (Unsupported in squeeze-lts)

Search for package or bug name: Reporting problems