CVE-2014-3488

NameCVE-2014-3488
DescriptionThe SslHandler in Netty before 3.9.2 allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via a crafted SSLv2Hello message.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
netty (PTS)jessie1:3.2.6.Final-2fixed
jessie (security)1:3.2.6.Final-2+deb8u1fixed
stretch (security), stretch1:4.1.7-2+deb9u1fixed
buster, buster (security)1:4.1.33-1+deb10u1fixed
bullseye, sid1:4.1.33-3fixed
netty-3.9 (PTS)jessie3.9.0.Final-1vulnerable
stretch3.9.9.Final-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nettysource(unstable)(not affected)
netty-3.9source(unstable)3.9.9.Final-1

Notes

- netty <not-affected> (Introduced in 3.9.0)
https://bugzilla.redhat.com/show_bug.cgi?id=1107983 says only affects
3.9.0 and 3.9.1.
https://github.com/netty/netty/issues/2562
https://github.com/netty/netty/commit/2fa9400a59d0563a66908aba55c41e7285a04994

Search for package or bug name: Reporting problems