DescriptionThe push_ascii function in smbd in Samba 3.6.x before 3.6.24, 4.0.x before 4.0.19, and 4.1.x before 4.1.9 allows remote authenticated users to cause a denial of service (memory corruption and daemon crash) via an attempt to read a Unicode pathname without specifying use of Unicode, leading to a character-set conversion failure that triggers an invalid pointer dereference.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitylow (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)wheezy2:3.6.6-6+deb7u7fixed
wheezy (security)2:3.6.6-6+deb7u10fixed
jessie (security), jessie2:4.2.10+dfsg-0+deb8u3fixed
stretch, sid2:4.4.6+dfsg-2fixed
samba4 (PTS)wheezy4.0.0~beta2+dfsg1-3.2+deb7u2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasourcesqueeze(not affected)


[squeeze] - samba <not-affected> (Only affects 3.6 and later)
AD-related packages removed from src:samba4 in 4.0.0~beta2+dfsg1-3.2+deb7u2

Search for package or bug name: Reporting problems