CVE-2014-3497

NameCVE-2014-3497
DescriptionCross-site scripting (XSS) vulnerability in OpenStack Swift 1.11.0 through 1.13.1 allows remote attackers to inject arbitrary web script or HTML via the WWW-Authenticate header.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs752087

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
swift (PTS)bullseye (security), bullseye2.26.0-10+deb11u1fixed
bookworm2.30.0-4fixed
sid, trixie2.33.0-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
swiftsourcewheezy(not affected)
swiftsource(unstable)1.13.1-1752087

Notes

[wheezy] - swift <not-affected> (Only affects 1.11.0 to 1.13.1)

Search for package or bug name: Reporting problems