CVE-2014-3505

NameCVE-2014-3505
DescriptionDouble free vulnerability in d1_both.c in the DTLS implementation in OpenSSL 0.9.8 before 0.9.8zb, 1.0.0 before 1.0.0n, and 1.0.1 before 1.0.1i allows remote attackers to cause a denial of service (application crash) via crafted DTLS packets that trigger an error condition.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDLA-33-1, DSA-2998-1
NVD severitymedium (attack range: remote)
Debian/oldstablepackage openssl is vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssl (PTS)squeeze (security), squeeze0.9.8o-4squeeze14vulnerable
squeeze (lts)0.9.8o-4squeeze20fixed
wheezy1.0.1e-2+deb7u13fixed
wheezy (security)1.0.1e-2+deb7u16fixed
jessie1.0.1k-1fixed
sid1.0.1k-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensslsource(unstable)1.0.1i-1medium
opensslsourcesqueeze0.9.8o-4squeeze17mediumDLA-33-1
opensslsourcewheezy1.0.1e-2+deb7u12mediumDSA-2998-1

Search for package or bug name: Reporting problems