CVE-2014-3509

NameCVE-2014-3509
DescriptionRace condition in the ssl_parse_serverhello_tlsext function in t1_lib.c in OpenSSL 1.0.0 before 1.0.0n and 1.0.1 before 1.0.1i, when multithreading and session resumption are used, allows remote SSL servers to cause a denial of service (memory overwrite and client application crash) or possibly have unspecified other impact by sending Elliptic Curve (EC) Supported Point Formats Extension data.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2998-1
NVD severitymedium (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssl (PTS)squeeze (security), squeeze0.9.8o-4squeeze14fixed
squeeze (lts)0.9.8o-4squeeze20fixed
wheezy1.0.1e-2+deb7u13fixed
wheezy (security)1.0.1e-2+deb7u16fixed
jessie1.0.1k-1fixed
sid1.0.1k-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensslsource(unstable)1.0.1i-1medium
opensslsourcesqueeze(not affected)
opensslsourcewheezy1.0.1e-2+deb7u12mediumDSA-2998-1

Notes

[squeeze] - openssl <not-affected> (vulnerable code not present)

Search for package or bug name: Reporting problems