CVE-2014-3514

NameCVE-2014-3514
Descriptionactiverecord/lib/active_record/relation/query_methods.rb in Active Record in Ruby on Rails 4.0.x before 4.0.9 and 4.1.x before 4.1.5 allows remote attackers to bypass the strong parameters protection mechanism via crafted input to an application that makes create_with calls.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)wheezy2:2.3.14.2fixed
jessie (security), jessie2:4.1.8-1+deb8u4fixed
stretch, sid2:4.2.7.1-1fixed
ruby-activerecord-2.3 (PTS)wheezy2.3.14-6fixed
ruby-activerecord-3.2 (PTS)wheezy3.2.6-5+deb7u1fixed
wheezy (security)3.2.6-5+deb7u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssource(unstable)2:4.1.5-1high
railssourcesqueeze(unfixed)end-of-life
railssourcewheezy(not affected)
rails-3.2source(unstable)(not affected)
ruby-activerecord-2.3source(unstable)(not affected)
ruby-activerecord-3.2source(unstable)(not affected)

Notes

[wheezy] - rails <not-affected> (Only affects 4.0.0 and all Later Versions)
[squeeze] - rails <end-of-life> (Unsupported in squeeze-lts)
- rails-3.2 <not-affected> (Only affects 4.0.0 and all Later Versions)
- ruby-activerecord-2.3 <not-affected> (Only affects 4.0.0 and all Later Versions)
- ruby-activerecord-3.2 <not-affected> (Only affects 4.0.0 and all Later Versions)

Search for package or bug name: Reporting problems