CVE-2014-3522

NameCVE-2014-3522
DescriptionThe Serf RA layer in Apache Subversion 1.4.0 through 1.7.x before 1.7.18 and 1.8.x before 1.8.10 does not properly handle wildcards in the Common Name (CN) or subjectAltName field of the X.509 certificate, which allows man-in-the-middle attackers to spoof servers via a crafted certificate.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
subversion (PTS)buster1.10.4-1+deb10u2fixed
buster (security)1.10.4-1+deb10u3fixed
bullseye (security), bullseye1.14.1-3+deb11u1fixed
bookworm, sid1.14.2-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
subversionsourcesqueeze(unfixed)unimportant
subversionsourcewheezy(unfixed)unimportant
subversionsource(unstable)1.8.10-1

Notes

https://subversion.apache.org/security/CVE-2014-3522-advisory.txt

Search for package or bug name: Reporting problems