CVE-2014-3528

NameCVE-2014-3528
DescriptionApache Subversion 1.0.0 through 1.7.x before 1.7.17 and 1.8.x before 1.8.10 uses an MD5 hash of the URL and authentication realm to store cached credentials, which makes it easier for remote servers to obtain the credentials via a crafted authentication realm.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
subversion (PTS)buster1.10.4-1+deb10u2fixed
buster (security)1.10.4-1+deb10u3fixed
bullseye (security), bullseye1.14.1-3+deb11u1fixed
bookworm, sid1.14.2-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
subversionsource(unstable)1.8.10-1low

Notes

[squeeze] - subversion <no-dsa> (Minor issue)
[wheezy] - subversion <no-dsa> (Minor issue)
http://mail-archives.apache.org/mod_mbox/subversion-dev/201407.mbox/%3C53DAB4A7.8030004%40reser.org%3E

Search for package or bug name: Reporting problems