CVE-2014-3532

NameCVE-2014-3532
Descriptiondbus 1.3.0 before 1.6.22 and 1.8.x before 1.8.6, when running on Linux 2.6.37-rc4 or later, allows local users to cause a denial of service (system-bus disconnect of other services or applications) by sending a message containing a file descriptor, then exceeding the maximum recursion depth before the initial message is forwarded.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2971-1
NVD severitylow (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dbus (PTS)wheezy, wheezy (security)1.6.8-1+deb7u6fixed
jessie1.8.22-0+deb8u1fixed
buster, sid, stretch1.10.18-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dbussource(unstable)1.8.6-1low
dbussourcesqueeze(not affected)
dbussourcewheezy1.6.8-1+deb7u3lowDSA-2971-1

Notes

[squeeze] - dbus <not-affected> (Fix for other kernel version)
https://bugs.freedesktop.org/show_bug.cgi?id=80163

Search for package or bug name: Reporting problems