CVE-2014-3533

NameCVE-2014-3533
Descriptiondbus 1.3.0 before 1.6.22 and 1.8.x before 1.8.6 allows local users to cause a denial of service (disconnect) via a certain sequence of crafted messages that cause the dbus-daemon to forward a message containing an invalid file descriptor.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-2971-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dbus (PTS)buster1.12.20-0+deb10u1fixed
bullseye1.12.20-2fixed
bookworm, sid1.14.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dbussourcesqueeze(not affected)
dbussourcewheezy1.6.8-1+deb7u3DSA-2971-1
dbussource(unstable)1.8.6-1

Notes

[squeeze] - dbus <not-affected> (Vulnerable code not present)
https://bugs.freedesktop.org/show_bug.cgi?id=80469

Search for package or bug name: Reporting problems