CVE-2014-3538

NameCVE-2014-3538
Descriptionfile before 5.19 does not properly restrict the amount of data read during a regex search, which allows remote attackers to cause a denial of service (CPU consumption) via a crafted file that triggers backtracking during processing of an awk rule. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7345.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-50-1, DLA-67-1, DSA-3008-1, DSA-3021-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
file (PTS)wheezy5.11-2+deb7u8fixed
wheezy (security)5.11-2+deb7u9fixed
jessie1:5.22+15-2+deb8u3fixed
stretch (security), stretch1:5.30-1+deb9u1fixed
buster, sid1:5.32-1fixed
php5 (PTS)wheezy5.4.45-0+deb7u2fixed
wheezy (security)5.4.45-0+deb7u11fixed
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
filesource(unstable)1:5.19-1medium
filesourcesqueeze5.04-5+squeeze7mediumDLA-50-1
filesourcewheezy5.11-2+deb7u4mediumDSA-3021-1
php5source(unstable)5.6.0~rc4+dfsg-1medium
php5sourcesqueeze5.3.3-7+squeeze22mediumDLA-67-1
php5sourcewheezy5.4.4-14+deb7u13mediumDSA-3008-1

Notes

fix relies on the new feature that introduced regex/<length> syntax, might be too intrusive for backporting.
https://bugs.php.net/bug.php?id=67705

Search for package or bug name: Reporting problems