CVE-2014-3580

NameCVE-2014-3580
DescriptionThe mod_dav_svn Apache HTTPD server module in Apache Subversion 1.x before 1.7.19 and 1.8.x before 1.8.11 allows remote attackers to cause a denial of service (NULL pointer dereference and server crash) via a REPORT request for a resource that does not exist.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-119-1, DSA-3107-1
NVD severitymedium (attack range: remote)
Debian Bugs773263

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
subversion (PTS)wheezy1.6.17dfsg-4+deb7u10fixed
wheezy (security)1.6.17dfsg-4+deb7u12fixed
jessie (security), jessie1.8.10-6+deb8u5fixed
stretch (security), stretch1.9.5-1+deb9u1fixed
buster1.9.7-2fixed
sid1.9.7-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
subversionsource(unstable)1.8.10-5medium773263
subversionsourcesqueeze1.6.12dfsg-7+deb6u1mediumDLA-119-1
subversionsourcewheezy1.6.17dfsg-4+deb7u7mediumDSA-3107-1

Notes

http://subversion.apache.org/security/CVE-2014-3580-advisory.txt

Search for package or bug name: Reporting problems