CVE-2014-3587

NameCVE-2014-3587
DescriptionInteger overflow in the cdf_read_property_info function in cdf.c in file through 5.19, as used in the Fileinfo component in PHP before 5.4.32 and 5.5.x before 5.5.16, allows remote attackers to cause a denial of service (application crash) via a crafted CDF file. NOTE: this vulnerability exists because of an incomplete fix for CVE-2012-1571.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-50-1, DLA-67-1, DSA-3008-1, DSA-3021-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
file (PTS)wheezy5.11-2+deb7u8fixed
wheezy (security)5.11-2+deb7u9fixed
jessie1:5.22+15-2+deb8u3fixed
stretch (security), stretch1:5.30-1+deb9u1fixed
buster, sid1:5.32-1fixed
php5 (PTS)wheezy5.4.45-0+deb7u2fixed
wheezy (security)5.4.45-0+deb7u11fixed
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
filesource(unstable)1:5.19-2medium
filesourcesqueeze5.04-5+squeeze7mediumDLA-50-1
filesourcewheezy5.11-2+deb7u4mediumDSA-3021-1
php5source(unstable)5.6.0+dfsg-1medium
php5sourcesqueeze5.3.3-7+squeeze22mediumDLA-67-1
php5sourcewheezy5.4.4-14+deb7u13mediumDSA-3008-1

Notes

https://bugs.php.net/bug.php?id=67716
https://github.com/php/php-src/commit/7ba1409a1aee5925180de546057ddd84ff267947

Search for package or bug name: Reporting problems