CVE-2014-3589

NameCVE-2014-3589
DescriptionPIL/IcnsImagePlugin.py in Python Imaging Library (PIL) and Pillow before 2.3.2 and 2.5.x before 2.5.2 allows remote attackers to cause a denial of service via a crafted block size.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-41-1, DSA-3009-1
NVD severitymedium (attack range: remote)
Debian Bugs758772

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pillow (PTS)jessie (security), jessie2.6.1-2+deb8u3fixed
stretch4.0.0-4fixed
buster, sid4.3.0-1fixed
python-imaging (PTS)wheezy1.1.7-4+deb7u2fixed
wheezy (security)1.1.7-4+deb7u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pillowsource(unstable)2.5.3-1medium758772
python-imagingsource(unstable)(unfixed)medium
python-imagingsourcesqueeze1.1.7-2+deb6u1medium
python-imagingsourcewheezy1.1.7-4+deb7u1mediumDSA-3009-1

Notes

https://github.com/python-pillow/Pillow/commit/205e056f8f9b06ed7b925cf8aa0874bc4aaf8a7d

Search for package or bug name: Reporting problems