CVE-2014-3591

NameCVE-2014-3591
DescriptionLibgcrypt before 1.6.3 and GnuPG before 1.4.19 does not implement ciphertext blinding for Elgamal decryption, which allows physically proximate attackers to obtain the server's private key by determining factors using crafted ciphertext and the fluctuations in the electromagnetic field during multiplication.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-175-1, DLA-190-1, DSA-3184-1, DSA-3185-1
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgcrypt20 (PTS)stretch (security), stretch1.7.6-2+deb9u3fixed
buster1.8.4-5fixed
bullseye, sid1.8.7-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnupgsourcesqueeze1.4.10-4+squeeze7DLA-175-1
gnupgsourcewheezy1.4.12-7+deb7u7DSA-3184-1
gnupgsource(unstable)1.4.18-7
libgcrypt11sourcesqueeze1.4.5-2+squeeze3DLA-190-1
libgcrypt11sourcewheezy1.5.0-5+deb7u3DSA-3185-1
libgcrypt11source(unstable)(unfixed)
libgcrypt20source(unstable)1.6.3-2

Notes

http://www.cs.tau.ac.il/~tromer/radioexp/
http://git.gnupg.org/cgi-bin/gitweb.cgi?p=gnupg.git;a=commit;h=ff53cf06e966dce0daba5f2c84e03ab9db2c3c8b

Search for package or bug name: Reporting problems