CVE-2014-3609

NameCVE-2014-3609
DescriptionHttpHdrRange.cc in Squid 3.x before 3.3.12 and 3.4.x before 3.4.6 allows remote attackers to cause a denial of service (crash) via a request with crafted "Range headers with unidentifiable byte-range values."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-216-1, DLA-45-1, DSA-3014-1, DSA-3139-1
NVD severitymedium (attack range: remote)
Debian Bugs759509, 776194

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid (PTS)wheezy2.7.STABLE9-4.1+deb7u1fixed
wheezy (security)2.7.STABLE9-4.1+deb7u2fixed
squid3 (PTS)wheezy3.1.20-2.2+deb7u4fixed
wheezy (security)3.1.20-2.2+deb7u7fixed
jessie (security), jessie3.4.8-6+deb8u4fixed
buster, sid, stretch3.5.23-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squidsource(unstable)2.7.STABLE9-5medium776194
squidsourcesqueeze2.7.STABLE9-2.1+deb6u1mediumDLA-216-1
squidsourcewheezy2.7.STABLE9-4.1+deb7u1mediumDSA-3139-1
squid3source(unstable)3.3.8-1.2medium759509
squid3sourcesqueeze3.1.6-1.2+squeeze4mediumDLA-45-1
squid3sourcewheezy3.1.20-2.2+deb7u2mediumDSA-3014-1

Notes

http://www.squid-cache.org/Advisories/SQUID-2014_2.txt

Search for package or bug name: Reporting problems