CVE-2014-3613

NameCVE-2014-3613
DescriptioncURL and libcurl before 7.38.0 does not properly handle IP addresses in cookie domain names, which allows remote attackers to set cookies for or send arbitrary cookies to certain sites, as demonstrated by a site at 192.168.0.1 setting cookies for a site at 127.168.0.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-64-1, DSA-3022-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)buster7.64.0-4+deb10u2fixed
buster (security)7.64.0-4+deb10u3fixed
bullseye7.74.0-1.3+deb11u3fixed
bullseye (security)7.74.0-1.3+deb11u2fixed
bookworm, sid7.86.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsourcesqueeze7.21.0-2.1+squeeze9DLA-64-1
curlsourcewheezy7.26.0-1+wheezy10DSA-3022-1
curlsource(unstable)7.38.0-1

Notes

http://curl.haxx.se/docs/adv_20140910A.html

Search for package or bug name: Reporting problems