CVE-2014-3616

NameCVE-2014-3616
Descriptionnginx 0.5.6 through 1.7.4, when using the same shared ssl_session_cache or ssl_session_ticket_key for multiple servers, can reuse a cached SSL session for an unrelated context, which allows remote attackers with certain privileges to conduct "virtual host confusion" attacks.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-55-1, DSA-3029-1
Debian Bugs761940

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nginx (PTS)bullseye (security), bullseye1.18.0-6.1+deb11u3fixed
bookworm1.22.1-9fixed
sid, trixie1.26.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nginxsourcesqueeze0.7.67-3+squeeze4DLA-55-1
nginxsourcewheezy1.2.1-2.2+wheezy3DSA-3029-1
nginxsource(unstable)1.6.2-1761940

Notes

http://mailman.nginx.org/pipermail/nginx-announce/2014/000147.html
Upstream patch: http://trac.nginx.org/nginx/changeset/1ee1db30c9b96e9e43e85ab0bfba42140af24966/nginx (stable-1.6 branch)
See follow up on: http://mailman.nginx.org/pipermail/nginx-devel/2014-September/005948.html

Search for package or bug name: Reporting problems