CVE-2014-3621

NameCVE-2014-3621
DescriptionThe catalog url replacement in OpenStack Identity (Keystone) before 2013.2.3 and 2014.1 before 2014.1.2.1 allows remote authenticated users to read sensitive configuration options via a crafted endpoint, as demonstrated by "$(admin_token)" in the publicurl endpoint field.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
keystone (PTS)buster, buster (security)2:14.2.0-0+deb10u1fixed
bullseye2:18.0.0-3+deb11u1fixed
bookworm, sid2:22.0.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
keystonesourcewheezy(not affected)
keystonesource(unstable)2014.1.3-1

Notes

[wheezy] - keystone <not-affected> (Vulnerable code not present)
up to 2013.2.3 and 2014.1 versions up to 2014.1.2.1

Search for package or bug name: Reporting problems