DescriptionCross-site scripting (XSS) vulnerability in the Admin UI Plugin / Stats page in Apache Solr 4.x before 4.10.3 allows remote attackers to inject arbitrary web script or HTML via the fieldvaluecache object.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lucene-solr (PTS)wheezy3.6.0+dfsg-1+deb7u1fixed
wheezy (security)3.6.0+dfsg-1+deb7u3fixed
jessie (security)3.6.2+dfsg-5+deb8u1fixed
stretch (security), stretch3.6.2+dfsg-10+deb9u1fixed
buster, sid3.6.2+dfsg-11fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lucene-solrsource(unstable)(not affected)


- lucene-solr <not-affected> (Only affects later 4.x releases)

Search for package or bug name: Reporting problems