CVE-2014-3634

NameCVE-2014-3634
Descriptionrsyslog before 7.6.6 and 8.x before 8.4.1 and sysklogd 1.5 and earlier allows remote attackers to cause a denial of service (crash), possibly execute arbitrary code, or have other unspecified impact via a crafted priority (PRI) value that triggers an out-of-bounds array access.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-72-1, DSA-3040-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
inetutils (PTS)wheezy2:1.9-2vulnerable
jessie2:1.9.2.39.3a460-3fixed
buster, sid, stretch2:1.9.4-2fixed
rsyslog (PTS)wheezy, wheezy (security)5.8.11-3+deb7u2fixed
jessie8.4.2-1+deb8u2fixed
stretch8.24.0-1fixed
buster, sid8.29.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
inetutilssource(unstable)2:1.9.2.39.3a460-1high
rsyslogsource(unstable)8.4.1-1high
rsyslogsourcesqueeze4.6.4-2+deb6u1highDLA-72-1
rsyslogsourcewheezy5.8.11-3+deb7u1highDSA-3040-1

Notes

[wheezy] - inetutils <no-dsa> (Minor issue)
[squeeze] - inetutils <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems