CVE-2014-3637

NameCVE-2014-3637
DescriptionD-Bus 1.3.0 through 1.6.x before 1.6.24 and 1.8.x before 1.8.8 does not properly close connections for processes that have terminated, which allows local users to cause a denial of service via a D-bus message containing a D-Bus connection file descriptor.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3026-1
NVD severitylow (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dbus (PTS)wheezy, wheezy (security)1.6.8-1+deb7u6fixed
jessie1.8.22-0+deb8u1fixed
stretch1.10.24-0+deb9u1fixed
buster, sid1.12.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dbussource(unstable)1.8.8-1low
dbussourcesqueeze(not affected)
dbussourcewheezy1.6.8-1+deb7u4lowDSA-3026-1

Notes

[squeeze] - dbus <not-affected> (Version in squeeze does not support FD passing with SCM_RIGHTS)
https://bugs.freedesktop.org/show_bug.cgi?id=80559

Search for package or bug name: Reporting problems