CVE-2014-3641

NameCVE-2014-3641
DescriptionThe (1) GlusterFS and (2) Linux Smbfs drivers in OpenStack Cinder before 2014.1.3 allows remote authenticated users to obtain file data from the Cinder-volume host by cloning and attaching a volume with a crafted qcow2 header.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cinder (PTS)buster2:13.0.3-1fixed
buster (security)2:13.0.7-1+deb10u2fixed
bullseye2:17.0.1-1fixed
bullseye (security)2:17.0.1-1+deb11u1fixed
bookworm2:21.0.0-3fixed
sid2:21.1.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cindersource(unstable)2014.1.3-1

Notes

Affects version up to 2014.1.2

Search for package or bug name: Reporting problems