CVE-2014-3683

NameCVE-2014-3683
DescriptionInteger overflow in rsyslog before 7.6.7 and 8.x before 8.4.2 and sysklogd 1.5 and earlier allows remote attackers to cause a denial of service (crash) via a large priority (PRI) value. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-3634.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-72-1, DSA-3047-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rsyslog (PTS)wheezy, wheezy (security)5.8.11-3+deb7u2fixed
jessie8.4.2-1+deb8u2fixed
stretch8.24.0-1fixed
buster, sid8.29.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rsyslogsource(unstable)8.4.2-1medium
rsyslogsourcesqueeze4.6.4-2+deb6u1mediumDLA-72-1
rsyslogsourcewheezy5.8.11-3+deb7u2mediumDSA-3047-1

Notes

http://www.rsyslog.com/remote-syslog-pri-vulnerability-cve-2014-3683/

Search for package or bug name: Reporting problems