CVE-2014-3684

NameCVE-2014-3684
DescriptionThe tm_adopt function in lib/Libifl/tm.c in Terascale Open-Source Resource and Queue Manager (aka TORQUE Resource Manager) 5.0.x, 4.5.x, 4.2.x, and earlier does not validate that the owner of the process also owns the adopted session id, which allows remote authenticated users to kill arbitrary processes via a crafted executable.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-78-1, DSA-3058-1
NVD severitymedium (attack range: remote)
Debian Bugs763922

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
torque (PTS)wheezy, wheezy (security)2.4.16+dfsg-1+deb7u4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
torquesource(unstable)2.4.16+dfsg-1.5medium763922
torquesourcesqueeze2.4.8+dfsg-9squeeze5mediumDLA-78-1
torquesourcewheezy2.4.16+dfsg-1+deb7u4mediumDSA-3058-1

Notes

https://github.com/adaptivecomputing/torque/commit/967cdc80150690459a47a35a658abeee0ca6e5cb
https://github.com/adaptivecomputing/torque/commit/f2f4c950f3d461a249111c8826da3beaafccace9
2.4 is end-of-life upstream thus no patches available for that branch.

Search for package or bug name: Reporting problems