CVE-2014-3686

NameCVE-2014-3686
Descriptionwpa_supplicant and hostapd 0.7.2 through 2.2, when running with certain configurations and using wpa_cli or hostapd_cli with action scripts, allows remote attackers to execute arbitrary commands via a crafted frame.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-147-1, DSA-3052-1
NVD severitymedium (attack range: remote)
Debian Bugs765352

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wpa (PTS)wheezy1.0-3+deb7u3fixed
wheezy (security)1.0-3+deb7u4fixed
jessie2.3-1+deb8u4fixed
jessie (security)2.3-1+deb8u5fixed
stretch2:2.4-1fixed
stretch (security)2:2.4-1+deb9u1fixed
buster, sid2:2.4-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
hostapdsource(unstable)(unfixed)medium
hostapdsourcesqueeze(not affected)
wpasource(unstable)2.3-1high765352
wpasourcewheezy1.0-3+deb7u1mediumDSA-3052-1
wpasupplicantsource(unstable)(unfixed)medium
wpasupplicantsourcesqueeze0.6.10-2.1+deb6u1mediumDLA-147-1

Notes

[squeeze] - hostapd <not-affected> (Vulnerable code not present in 0.6.10)

Search for package or bug name: Reporting problems