CVE-2014-3966

NameCVE-2014-3966
DescriptionCross-site scripting (XSS) vulnerability in Special:PasswordReset in MediaWiki before 1.19.16, 1.21.x before 1.21.10, and 1.22.x before 1.22.7, when wgRawHtml is enabled, allows remote attackers to inject arbitrary web script or HTML via an invalid username.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2957-1
NVD severitylow (attack range: remote, user-initiated)
Debian Bugs750527
Debian/oldoldstablepackage mediawiki is vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)squeeze, squeeze (security)1:1.15.5-2squeeze6vulnerable
wheezy, wheezy (security)1:1.19.20+dfsg-0+deb7u3fixed
stretch, sid, jessie1:1.19.20+dfsg-2.3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisource(unstable)1:1.19.16+dfsg-1low750527
mediawikisourcesqueeze(unfixed)end-of-life
mediawikisourcewheezy1:1.19.16+dfsg-0+deb7u1lowDSA-2957-1

Notes

https://bugzilla.wikimedia.org/show_bug.cgi?id=65501

Search for package or bug name: Reporting problems