CVE-2014-4000

NameCVE-2014-4000
DescriptionCacti before 1.0.0 allows remote authenticated users to conduct PHP object injection attacks and execute arbitrary PHP code via a crafted serialized object, related to calling unserialize(stripslashes()).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cacti (PTS)jessie0.8.8b+dfsg-8+deb8u6fixed
jessie (security)0.8.8b+dfsg-8+deb8u7fixed
stretch0.8.8h+ds1-10fixed
buster1.2.2+ds1-2fixed
bullseye, sid1.2.4+ds1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cactisource(unstable)0.8.8e+ds1-1low
cactisourcejessie0.8.8b+dfsg-8+deb8u2medium
cactisourcewheezy0.8.8a+dfsg-5+deb7u6medium

Notes

http://www.cacti.net/release_notes_1_0_0.php
http://bugs.cacti.net/view.php?id=2452 (not accessible: marked as security issue)
http://svn.cacti.net/viewvc?view=rev&revision=7731
This CVE was fixed by introduction of the function sanitize_unserialize_selected_items
in version 0.8.8e and calling it instead of unserialize(stripslashes()).
Affected files require authenticated users.

Search for package or bug name: Reporting problems