CVE-2014-4021

NameCVE-2014-4021
DescriptionXen 3.2.x through 4.4.x does not properly clean memory pages recovered from guests, which allows local guest OS users to obtain sensitive information via unspecified vectors.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-3006-1
NVD severitylow (attack range: remote)
Debian Bugs751894
Debian/oldoldstablepackage xen is vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)squeeze, squeeze (security)4.0.1-5.11vulnerable
wheezy4.1.4-3+deb7u3fixed
wheezy (security)4.1.4-3+deb7u8fixed
stretch, sid, jessie4.4.1-9fixed
jessie (security)4.4.1-9+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)4.4.1-1low751894
xensourcesqueeze(unfixed)end-of-life
xensourcewheezy4.1.4-3+deb7u2lowDSA-3006-1

Notes

[squeeze] - xen <end-of-life> (Unsupported in squeeze-lts)

Search for package or bug name: Reporting problems