CVE-2014-4037

NameCVE-2014-4037
DescriptionCross-site scripting (XSS) vulnerability in editor/dialog/fck_spellerpages/spellerpages/server-scripts/spellchecker.php in FCKeditor before 2.6.11 and earlier allows remote attackers to inject arbitrary web script or HTML via an array key in the textinputs[] parameter, a different issue than CVE-2012-4000.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs752873

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
moin (PTS)jessie1.9.8-1+deb8u1fixed
jessie (security)1.9.8-1+deb8u2fixed
buster, sid, stretch (security), stretch1.9.9-1+deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
docvertsource(unstable)(unfixed)medium
fckeditorsource(unstable)(unfixed)low752873
knowledgerootsource(unstable)(not affected)
moinsource(unstable)(not affected)

Notes

[wheezy] - fckeditor <no-dsa> (Minor issue)
[squeeze] - fckeditor <no-dsa> (Minor issue)
[wheezy] - docvert <no-dsa> (Minor issue)
[squeeze] - docvert <no-dsa> (Minor issue)
- moin <not-affected> (unused emebdded copy)
- knowledgeroot <not-affected> (unused embedded copy)

Search for package or bug name: Reporting problems