CVE-2014-4040

NameCVE-2014-4040
Descriptionsnap in powerpc-utils 1.2.20 produces an archive with fstab and yaboot.conf files potentially containing cleartext passwords, and lacks a warning about reviewing this archive to detect included passwords, which might allow remote attackers to obtain sensitive information by leveraging access to a technical-support data stream.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
powerpc-utils (PTS)wheezy1.1.3-24vulnerable
jessie1.1.3-25vulnerable
buster, sid, stretch1.3.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
powerpc-utilssource(unstable)1.3.1-2unimportant

Notes

SuSE decided to put/display a warning about the possibility to of
containing cleartext passwords in the produced archive containing fstab
and yaboot.conf
1.3.1-2 upload removed /usr/sbin/snap from the installed binary package

Search for package or bug name: Reporting problems