CVE-2014-4049

NameCVE-2014-4049
DescriptionHeap-based buffer overflow in the php_parserr function in ext/standard/dns.c in PHP 5.6.0beta4 and earlier allows remote servers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted DNS TXT record, related to the dns_get_record function.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDLA-0010-1, DSA-2961-1
NVD severitymedium (attack range: remote)
Debian Bugs751364
Debian/oldoldstablepackage php5 is vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)squeeze, squeeze (security)5.3.3-7+squeeze19vulnerable
squeeze (lts)5.3.3.1-7+squeeze26fixed
wheezy5.4.36-0+deb7u1fixed
wheezy (security)5.4.44-0+deb7u1fixed
jessie5.6.7+dfsg-1fixed
jessie (security)5.6.12+dfsg-0+deb8u1fixed
stretch5.6.11+dfsg-1fixed
sid5.6.12+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)5.6.0~beta4+dfsg-3medium751364
php5sourcesqueeze5.3.3-7+squeeze20medium
php5sourcewheezy5.4.4-14+deb7u11mediumDSA-2961-1

Notes

https://github.com/php/php-src/commit/b34d7849ed90ced9345f8ea1c59bc8d101c18468

Search for package or bug name: Reporting problems