CVE-2014-4199

NameCVE-2014-4199
Descriptionvm-support 0.88 in VMware Tools, as distributed with VMware Workstation through 10.0.3 and other products, allows local users to write to arbitrary files via a symlink attack on a file in /tmp.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs770809

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
open-vm-tools (PTS)buster2:10.3.10-1+deb10u2fixed
buster (security)2:10.3.10-1+deb10u6fixed
bullseye (security), bullseye2:11.2.5-2+deb11u3fixed
bookworm, bookworm (security)2:12.2.0-1+deb12u2fixed
trixie2:12.3.5-4fixed
sid2:12.3.5-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
open-vm-toolssource(unstable)2:9.4.6-1770165-7low770809

Notes

[squeeze] - open-vm-tools <no-dsa> (Minor issue)
[wheezy] - open-vm-tools <no-dsa> (Minor issue)
http://seclists.org/fulldisclosure/2014/Aug/71

Search for package or bug name: Reporting problems