CVE-2014-4341

NameCVE-2014-4341
DescriptionMIT Kerberos 5 (aka krb5) before 1.12.2 allows remote attackers to cause a denial of service (buffer over-read and application crash) by injecting invalid tokens into a GSSAPI application session.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-37-1, DSA-3000-1
NVD severitymedium
Debian Bugs753624

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
krb5 (PTS)stretch1.15-1+deb9u1fixed
stretch (security)1.15-1+deb9u3fixed
buster1.17-3+deb10u3fixed
buster (security)1.17-3+deb10u2fixed
bullseye1.18.3-6+deb11u1fixed
bookworm, sid1.18.3-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
krb5sourcesqueeze1.8.3+dfsg-4squeeze8
krb5sourcewheezy1.10.1+dfsg-5+deb7u2DSA-3000-1
krb5source(unstable)1.12.1+dfsg-4753624

Notes

https://github.com/krb5/krb5/commit/fb99962cbd063ac04c9a9d2cc7c75eab73f3533d

Search for package or bug name: Reporting problems