CVE-2014-4342

NameCVE-2014-4342
DescriptionMIT Kerberos 5 (aka krb5) 1.7.x through 1.12.x before 1.12.2 allows remote attackers to cause a denial of service (buffer over-read or NULL pointer dereference, and application crash) by injecting invalid tokens into a GSSAPI application session.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDLA-37-1, DSA-3000-1
NVD severitymedium (attack range: remote)
Debian Bugs753625
Debian/oldstablepackage krb5 is vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
krb5 (PTS)squeeze (security), squeeze1.8.3+dfsg-4squeeze7vulnerable
squeeze (lts)1.8.3+dfsg-4squeeze9fixed
wheezy1.10.1+dfsg-5+deb7u2fixed
wheezy (security)1.10.1+dfsg-5+deb7u3fixed
jessie, sid1.12.1+dfsg-19fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
krb5source(unstable)1.12.1+dfsg-4medium753625
krb5sourcesqueeze1.8.3+dfsg-4squeeze8medium
krb5sourcewheezy1.10.1+dfsg-5+deb7u2mediumDSA-3000-1

Notes

https://github.com/krb5/krb5/commit/fb99962cbd063ac04c9a9d2cc7c75eab73f3533d

Search for package or bug name: Reporting problems