CVE-2014-4344

NameCVE-2014-4344
DescriptionThe acc_ctx_cont function in the SPNEGO acceptor in lib/gssapi/spnego/spnego_mech.c in MIT Kerberos 5 (aka krb5) 1.5.x through 1.12.x before 1.12.2 allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via an empty continuation token at a certain point during a SPNEGO negotiation.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDLA-37-1, DSA-3000-1
NVD severityhigh (attack range: remote)
Debian Bugs755521
Debian/oldoldstablepackage krb5 is vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
krb5 (PTS)squeeze, squeeze (security)1.8.3+dfsg-4squeeze7vulnerable
squeeze (lts)1.8.3+dfsg-4squeeze9fixed
wheezy1.10.1+dfsg-5+deb7u2fixed
wheezy (security)1.10.1+dfsg-5+deb7u3fixed
jessie1.12.1+dfsg-19fixed
stretch1.12.1+dfsg-20fixed
sid1.13.2+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
krb5source(unstable)1.12.1+dfsg-5high755521
krb5sourcesqueeze1.8.3+dfsg-4squeeze8high
krb5sourcewheezy1.10.1+dfsg-5+deb7u2highDSA-3000-1

Notes

https://github.com/krb5/krb5/commit/524688ce87a15fc75f87efc8c039ba4c7d5c197b

Search for package or bug name: Reporting problems